Degraded Performance: Square Messages
Incident Report for Square US
Resolved
We can confirm that the issues impacting Square Messages have now been fully resolved. We know how detrimental service disruptions can be to the functionality of your business.

Thank you for your continued patience during this time while our team and messaging partners worked together to resolve this.
Posted Dec 13, 2022 - 16:40 PST
Update
Our engineers have made significant progress this week working with our Messaging Partners to address the disruption affecting Square SMS Messages. We'll continue providing updates here as soon as we receive them.

Thank you for your continued patience.
Posted Dec 10, 2022 - 08:29 PST
Update
Square’s outbound transactional and marketing messages have been working for the past 9 days and we're working on restoring the bi-directional SMS "Chat" function. We've got the right people on this and we're fully committed to resolving the problem as soon as we can. Thank you for your continued patience.
Posted Dec 08, 2022 - 18:32 PST
Update
We know how important it is for our Sellers to be able to reach their customers via SMS. Our engineers are still working with our Messaging Partners on getting this disruption resolved. Progress has been made but there are still elements that need to be addressed to reestablish this feature.

We will provide updates here as they happen. Thank you for your understanding.
Posted Dec 08, 2022 - 07:05 PST
Update
We are aware of the current disruption affecting some Square SMS messages. Thank you for your continued patience while our team continues to work with our Messaging Partners on making this feature available to our Sellers.

We will continue sharing updates here as they occur.
Posted Dec 07, 2022 - 11:19 PST
Update
We appreciate your continued understanding as our team continues working with our messaging partners to fix this issue. Once we have another update, we will post that here.
Posted Dec 06, 2022 - 07:31 PST
Update
Our engineers are continuing to work with our messaging partners to resolve this issue. We thank you for your continued patience and we will provide further updates as they come in.
Posted Dec 04, 2022 - 09:38 PST
Update
Our engineers are continuing to collaborate with messaging partners to resolve the disruption affecting Square SMS Messages.

In the meantime, Sellers affected by this disruption can opt to message their customers via email.  To accomplish this, you will click on the "..." that appears above the conversation panel, click "Change Medium", choose the "Email" option, and save the changes.

We are thankful for your understanding and patience while our team addresses this disruption.
Posted Dec 02, 2022 - 11:05 PST
Update
Our engineers have identified the issue and are currently working to resolve this as quickly as possible. We thank you for your continued patience. We'll be back with further updates as they come to hand.
Posted Dec 01, 2022 - 09:26 PST
Update
Our team is continuing to work on restoring SMS notifications for Messages sent through Square Messages.

Previous SMS issues with other Square services have been fully resolved.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 18:36 PST
Update
Our team is continuing to work on restoring SMS notifications for multiple Square services. Services currently impacted are Square Invoices and Messages sent through Square Messages.

Digital Receipts, Appointments, Loyalty and Square Online order SMS notifications are working again.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 18:28 PST
Update
Our team is continuing to investigate issues sending SMS notifications from Square products. Services potentially impacted are Square Loyalty, Invoices, Messages sent through Square Messages.

Digital Receipts, Square Appointments and Square Online order SMS notifications are working again.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 17:03 PST
Update
Our team is continuing to investigate issues sending SMS notifications from Square products.

Services potentially impacted are Square Loyalty, Invoices, Messages sent through Square Messages and Square Online order updates.

Digital Receipts and Square Appointments SMS notifications are working again.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 16:49 PST
Update
Our team is continuing to investigate issues sending SMS notifications from Square products.

Services potentially impacted are Square Loyalty, Appointments, Invoices, Messages sent through Square Messages and Square Online order updates.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 16:24 PST
Update
Our team is continuing to investigate issues sending SMS notifications from Square products.
Services potentially impacted are Square Loyalty, Appointments, Invoices, Digital Receipts, Messages sent through Square Messages and Square Online order updates.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 16:13 PST
Identified
Our team is continuing to investigate issues sending SMS notifications from Square products.

Thank you for your patience with us as we work to resolve this issue.
Posted Nov 29, 2022 - 15:59 PST
Investigating
We are receiving confirmed reports of Sellers unable to send SMS messages through Square Messenger. We appreciate your patience as we are actively working with our Engineering team to get things back up.
Posted Nov 29, 2022 - 15:32 PST