Transfers Disruption
Incident Report for Square US
Resolved
We have resolved the disruption impacting the bank account verification process. Thank you for your patience with us as we worked to resolve this issue.
Posted Mar 27, 2024 - 13:25 PDT
Update
Our engineers are investigating a disruption impacting the bank account verification process. This delay in verification may have an impact on transfers being sent. We will continue monitoring it and will be back with further updates.
Posted Mar 27, 2024 - 13:10 PDT
Investigating
We are currently experiencing a disruption that is impacting some Square services. We understand how important it is for your business for all of our services to be up and running, and our Engineering team is actively working on a fix. Thank you for your patience with us as we work to resolve this issue.
Posted Mar 27, 2024 - 10:50 PDT