Limited Phone Support : North America
Incident Report for Square US
Resolved
Thank you for your patience and understanding today while we experienced higher than normal call volumes.
Posted Nov 26, 2021 - 18:14 PST
Investigating
North American Sellers seeking phone support will experience higher than expected wait times on Thursday, November 25th & Friday, November 26th.

Our teams are working diligently to assist all our Sellers over the phone, and appreciate your patience as we work to answer all support requests.

If your issue is not urgent, we recommend visiting squareup.com/help or sellercommunity.com for answers to common questions.

If your issue is urgent, and you choose to call in, we recommend requesting a callback when the option is available. You will not lose your place in line.
Posted Nov 24, 2021 - 17:50 PST
This incident affected: Phone Support.