Kitchen Display System (KDS) Disruption
Incident Report for Square US
Resolved
The disruption affecting Square KDS is now fully resolved and the service is now working normally. We thank you for your patience and understanding while we worked to address this today.
Posted Mar 22, 2024 - 18:10 PDT
Monitoring
We’ve implemented a fix to address the disruption affecting Square KDS’ performance. We continue to monitor progress and expect this issue to resolve shortly. Thank you for your patience.
Posted Mar 22, 2024 - 17:52 PDT
Update
Our engineers continue actively working to address the disruption affecting Square KDS. We thank you for your continued patience.
Posted Mar 22, 2024 - 17:39 PDT
Investigating
We’re experiencing a disruption that is affecting the performance of Square KDS. Engineers are actively working to address this situation. At this time, orders may not be appearing on Square KDS or may take longer than expected to appear. We will continue providing updates as they become available. Thank you for your patience.
Posted Mar 22, 2024 - 16:30 PDT