Degraded Performance: Square Terminal and Square Register Network Connection
Incident Report for Square US
Resolved
We have confirmed the disruption affecting Network Connectivity on Square Register and Terminal has been corrected by our engineers on the latest update. Please make sure to update your Square Register or Terminal to version 6.4b.

We cannot thank you enough for your patience while we worked to get this resolved!
Posted Nov 26, 2022 - 07:04 PST
Identified
Our engineers have released a fix for network connection issues with Square Register. If you are using Square Register please update to version 6.4 of the Square Register software.

We're continuing to work on a fix for Square Terminal, and appreciate your patience as we work to resolve this issue.
Posted Nov 17, 2022 - 21:32 PST
Update
Our engineers have released a fix for network connection issues with Square Register. If you are using Square Register please update to version 6.4 of the Square Register software.

We're continuing to work on a fix for Square Terminal, and appreciate your patience as we work to resolve this issue.
Posted Nov 17, 2022 - 21:31 PST
Monitoring
Our engineers have released a fix to resolve the issue impacting Square Register and Square Terminal. We will continue monitoring the progress of the fix until fully resolved. We appreciate your patience as we work to repair this issue. We will be sure to provide additional updates as we receive them.
Posted Nov 17, 2022 - 08:34 PST
Identified
Our engineering team have identified the issue causing network disturbance with some Square Registers and Square Terminals. They are working on getting a fix in place and will update you as soon as the issue is fully resolved.
In the meantime, if you are experiencing a network issue with your Register or Terminal, please follow the troubleshooting steps below.

Thanks again for your patience.
Posted Nov 15, 2022 - 08:53 PST
Investigating
If you are experiencing network issues with your Square Register or Square Terminal, please run through the troubleshooting steps below and ensure you meet the network requirements listed in the articles. Please do not factory reset your device*

Square Terminal: https://squ.re/3FR4iFF
Square Register: https://squ.re/3NImC5F

Thank you for your patience while our engineers continue to work on a fix for this issue.
Posted Nov 09, 2022 - 10:28 PST
This incident affected: Square Hardware.