Degraded Performance: Square Teams
Incident Report for Square US
Resolved
Our engineering has resolved the root cause and now you will not be seeing the issues when trying to edit items as a team member.
We recommend restarting the browser to see normal functionality restored.

Thank you for your patience with us through this.
Posted Dec 02, 2022 - 11:34 PST
Identified
Our engineering team has reported a disruption impacting some team members' ability to access the Item Edit page. We are actively working on correcting this and will provide more updates as we receive them.
Posted Dec 02, 2022 - 09:45 PST
Investigating
We are currently experiencing a disruption that is impacting some Square services. We understand how important it is for your business for all of our services to be up and running, and our Engineering team is actively working on a fix. Thank you for your patience with us as we work to resolve this issue.
Posted Dec 02, 2022 - 09:13 PST
This incident affected: Square Staff.