Degraded Performance: Square Retail
Incident Report for Square US
Resolved
Our engineering team has confirmed that the issue a small number of Square for Retail sellers were experiencing is now stable.
If you do experience a crash of this nature on Square for Retail on Square Register, please check for any available updates:

1. Tap the down arrow at the top of your Square Register.
2. Select Settings.
3. Tap Hardware > General > About Register.
4. Tap Software Update. If there is no update, your software is up to date.

Thank you for bearing with us while our team worked to resolve this issue.
Posted Aug 04, 2022 - 07:05 PDT
Monitoring
We've received reports from a small number of Square for Retail sellers experiencing unexpected app crashes on the item details page. Our engineers have confirmed this can occur where an item exists in an inventory with set minimum and maximum modifiers. This issue is currently only impacting the Retail app for Square Register. iOS devices are not impacted.

We've started rolling out an early update to app version 5.97 for impacted accounts. If you have experienced crashes of this nature on Square for Retail on Square Register, please check for any available updates:

1. Tap the down arrow at the top of your Square Register.
2. Select Settings.
3. Tap Hardware > General > About Register.
4. Tap Software Update. If there is no update, your software is up to date.

Our team is continuing to monitor this issue for sellers experiencing unexpected crashes per the above conditions and will continue to work on rolling out 5.97 for impacted sellers.
Posted Aug 03, 2022 - 20:55 PDT
Update
We've received reports from a small number of Square for Retail sellers experiencing unexpected app crashes on the item details page. Our engineers have confirmed that this can occur where an item exists in an inventory with set minimum and maximum modifiers. This issue is currently only impacting the Retail app for Square Register. iOS devices are not impacted.

Our team is continuing to work on a fix and we'll share more as it becomes available. Thanks again for your patience as we work to resolve this issue.
Posted Aug 03, 2022 - 17:43 PDT
Identified
We've received reports from a small number of Square for Retail sellers experiencing unexpected app crashes on the item details page. Our engineers have confirmed that this can occur where an item exists in an inventory with set minimum and maximum modifiers.

Our team is continuing to work on a fix and we'll share more as it becomes available. Thanks again for your patience as we work to resolve this issue.
Posted Aug 03, 2022 - 17:20 PDT
Investigating
We've received confirmed reports of issues impacting the ability to access item modifiers through Square for Retail, resulting in the item editing page crashing unexpectedly. This issue is currently only affecting Android devices - including the Square Register and Square Terminal.

Our team is working on a resolution and will update you as we have more information.

We appreciate your patience while we look to get this resolved.
Posted Aug 03, 2022 - 13:46 PDT
This incident affected: Square for Retail.