Dashboard Disruption
Incident Report for Square US
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 13:56 PST
Identified
We are continuing to work on a fix for a disruption currently impacting some Square services. We understand how important it is for all of our services to be running for your business, we’ll be back with further updates as they come to hand. Thank you for your patience with us as we work to resolve this issue.
Posted Nov 22, 2022 - 13:35 PST
Investigating
We are currently experiencing a disruption that is impacting some Square services. We understand how important it is for your business for all of our services to be up and running, and our Engineering team is actively working on a fix. Thank you for your patience with us as we work to resolve this issue.
Posted Nov 22, 2022 - 13:33 PST