Limited Phone Support
Incident Report for Square US
Resolved
The earlier technical issues we saw with our phone lines have been resolved. Thanks for your patience as we worked on fixing the issue.
Posted Aug 09, 2022 - 19:34 PDT
Investigating
We're experiencing technical issues with our support phone lines at the moment. Thanks for your patience as we work to resolve these issues.
Posted Aug 09, 2022 - 18:39 PDT
This incident affected: Phone Support.